查看内容

Centos 6.5 升级python2.6到python2.7

  • 2020-03-18 20:07
  • 新浦京计算机网络
  • Views

wget

Centos 6.5操作系统深度依赖python2.6,很多常用的系统工具都是基于python2.6的,比如yum等。所以在升级python时,不能删除2.6版本

python ez_setup.py

1 下载安装python2.7

$ wget https://www.python.org/ftp/python/2.7.12/Python-2.7.12.tgz
$ tar zxvf Python-2.7.12.tgz
$ cd Python-2.7.12
$ ./configure --prefix=/usr/local
$ make
# 安装时需要切换到root或者使用sudo指令
sudo make install

./configure指令的--prefix=/usr/local参数,指的python2.7的安装目录。因为系统python的可执行目录在/usr/bin下,在安装python2.7时需要与系统python2.6区分开来。其实、在安装python-2.7.12时,--prefix=/usr/local参数是可以不写的,因为./configure指令默认情况下就是指定/usr/local作为安装目录的。
在安装成功之后,可以在/usr/local/bin目录下找到如下几个python可执行文件:

$ ls python*
python python2 python2.7 python-config python2-config python2.7-config

其中、python python2是指向python2.7的软连接;python-config python2-config是指向python2.7-config的软连接;这些软连接有可能会与系统/usr/bin目录下的python相关命令冲突,这里将/usr/local/bin目录下的软连接备份并删除,重新创建一个python2.7的软连接:

# ln -s python2.7 python27
# ls python27
lrwxrwxrwx. 1 root root 9 Aug 29 10:42 python27 -> python2.7

在命令行,直接键入python27就可以进入python2.7开发环境;在开发python2.7的脚本程序时,需要在python脚本最开始添加#!/usr/local/bin/python27以确定当前脚本需要使用python2.7执行

上一篇:linux iconv方法的使用 下一篇:没有了